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Purpose of This Document

Purpose of This Document
This document contains instructions on how to set up and use the enhancements implemented in the EDC
v6.5.x enhancement release. In some instances, we combine features together to better explain the new
enhancements. When applicable, we include a scenario, how to configure the feature in Aloha® Manager,
how to use the feature in the Front-of-House (FOH), and references to other materials to fully implement
the feature. This document is not intended to fully explain a particular function or other options available
or surrounding the function. For your convenience, the material for each enhancement begins on a new
page, so you can properly remove and distribute the material to the necessary recipients. This document
does not guarantee the options discussed are in the same location, nor that the functionality remains the
same due to enhancements implemented in future versions of the affected products.

EDC Version Compatibility and Dependencies
Beginning with Aloha EDC versions 6.4 and later, EDC adopted a policy of assured backwards compatibility with Aloha POS versions 6.1.23 and later, 6.2.16 and later, and 6.4.7 and later. Generally speaking,
you can upgrade to a newer version of EDC to take advantage of new features, and to comply with new
processor requirements, without having to upgrade the POS. However, some new features require an
upgrade to both the EDC and POS products. Although you must upgrade your HASP key to Aloha v6.5 to
run Aloha EDC v6.5, this change in license status does not require you to upgrade the POS to Aloha v6.5.
Refer to RKS ID10265 “Aloha EDC and Aloha Point-of-Sale Version Compatibility and Dependencies” for clarity on POS and EDC version compatibility. Refer to the POS Enhancement
Release v6.5 document for detailed information on the POS enhancements in v6.5.

Installation Methods for Aloha EDC v6.5
You can create an Aloha Update executable file to install Aloha EDC v6.5, or you can install it manually, if
you have the component files. We recommend you use the Aloha Update method, as this process uses the
rollback feature to restore the previous version immediately, if it encounters any problems. The rollback
feature can help you avoid downtime in your business, if the upgrade does not proceed as expected.
Refer to the Aloha Update documentation for information about how to create, configure, and
use an Aloha Update executable file to upgrade your current EDC installation.
Use the following procedure, if you decide to install EDC v6.5 manually, without using an Aloha installation CD:
1. Process all outstanding transactions, and settle all pending batches. This step is of extreme
importance, to avoid losing sales data.
2. Stop POS Processing, in EDC.
3. Unregistered Deceiver.
4. Install all prerequisites on the BOH file server:
a. Microstate.NET Framework 2.0 (required by processors using the Universal Payment Interface (UPI).
b. Microstate Visual C++ Redistributive 2005 SP1 (as VCRedist_x86.exe).
EDC Enhancement Release v6.5
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5. Use an Aloha Update file to upgrade your EDC installation, as described in the Supporters document, ‘Aloha Update.’
Or
Place the following files into the %Iberdir%\Bin directory, on the Aloha BOH file server, replacing any existing files of the same name:
a. AmexAlohaUPI.dll. Place this file in the %Iberdir%\Bin directory only if you want to use the
new CAPN, high speed authorization, settlement, and prepaid card functionality.
b. ChillkatDotNet2.dll.
c. Dbghelp.dll.
d. Edc.exe.
e. Edcsec.dll.
f. EdcSvr.dll.
g. EdcSvr.UpiClient.Interop.dll.
h. EdcSvrps.dll.
i. Ipwssl6.dll.
j. Log4net.dll.
k. NovaAlohaUPI.dll. Place this file in the %Iberdir%\Bin directory only if you want to use the
new Nova functionality.
6. Register EDCSvr. This step is required, regardless of installation method used.
7. Start POS Processing in EDC.
Refer to Radiant Knowledge System document number 5989 for more information about how to
unregister and register Aloha application files.
If you upgrade to EDC v6.5, and then use Aloha Update to upgrade your Aloha POS to a version
earlier than 6.5, this installation overwrites your previous EDC v6.5 installation. You must reinstall EDC v6.5 after upgrading your Aloha POS, but before you begin accepting transactions for
the new business day.
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List of Enhancements by Product

List of Enhancements by Product
Version

RFC Number Description

EDC v6.5

RFC 18312

“Supporting Domestic Debit Cards for Paymentech” on page 6

EDC v6.5.3

RFC 24577

“Supporting PMS Interface via TCP/IP” on page 7

EDC v6.5

RFC 41398

EDC v6.5.5
EDC v6.5

RFC 44650
RFC 73342
RFC 45770

“Supporting Paymentech for Canadian Credit and Debit Cards” on
page 9
“Supporting Timeout Ability in Aloha EDC” on page 11

EDC v6.5

RFC 61214

“Supporting Partial Authorizations with Paymentech” on page 14

EDC 6.5.3

RFC 63625

“Introducing Token Replacement” on page 18

EDC v6.5

RFC 63711

“Supporting Partial and Split Payments with Chip and PIN” on page 21

EDC v6.5

RFC 63993

“Supporting AVS with Paymentech” on page 22

EDC 6.5.3

RFC 68643

“Improving PMS Sales Category Messaging” on page 23

EDC v6.5.3

RFC 69164

“Introducing Radiant Payment Services” on page 24

EDC v6.5.4

RFC 73343

“Introducing EDC Audit Transaction Report” on page 26

EDC 6.5.5

RFC 73596

“Adding PCI Disclaimer Message in EDC” on page 28
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Supporting Domestic Debit Cards for Paymentech

Supporting Domestic Debit Cards for
Paymentech
Version

RFC Number

Products

Audience

v6.5

RFC 18312

Aloha EDC

Configuration Technician
Store Manager

Debit support in the United States is currently supported by Global Payments, RBS WorldPay, and Visanet.
In v6.5, you can now use debit cards with Chase Paymentech.
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Supporting PMS Interface via TCP/IP
Version

RFC Number

Products

Audience

v6.5.3

RFC 24577

Aloha EDC, PMS

Configuration Technician

Prior to EDC v6.5.3, the only method of communication with a property management system was through
using RS-232 (Recommended Standard 232). Now, you can connect with a property management system
using a TCP/IP connection, for greater accessibility and faster responses. This feature works with all property management systems Aloha supports, and there is no failover mechanism available.
Refer to the Interfacing Aloha with PMS User Guide for more information on configuring and
using a property management system with Aloha POS.
To configure the property management system to communicate using TCP/IP:
1. Launch Aloha EDC.
2. If POS processing is turned on, select File > Stop POS Processing.
3. Select PMS > Parms.

Figure 1 PMS Parms Dialog Box

4. Select TCP/IP from the ‘Pms Host Link’ drop-down list.
5. Type the address of the PMS server in the ‘Host IP Address’ text box. The default is ‘localhost,’
which you can use if the PMS server and the EDC server reside on the same machine; otherwise,
you must type a valid IP address.
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6. Type the port number that matches the port of the PMS server.
7. Click OK.
8. Select File > Start POS Processing.

EDC Enhancement Release v6.5
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Supporting Paymentech for Canadian Credit and
Debit Cards
Version

RFC Number

Products

v6.5

RFC 41398

Aloha EDC

Audience
Configuration Technician
Store Manager

Aloha now supports using Paymentech as a processor over high-speed connections in Canada.

Support for Paymentech debit cards requires EDC v6.5 or higher and POS v6.5 or higher.
To enable Canadian Debit for Paymentech:
1. Select Maintenance > Store Settings > Credit Card group > EDC Setup tab.
2. Select Paymentech from the ‘Use Canadian Debit’ drop-down list.
3. Click Save and exit the Store Settings function.
To attach a PIN Pad to a terminal:
1.
2.
3.
4.

Select Maintenance > Hardware > Terminals > Other tab.
Select a terminal and press Enter.
Select Verifone SC 5000 from the ‘Type’ drop-down list.
Click Save and exit the Terminals function.

To assign a debit tender:
1.
2.
3.
4.
5.
6.
7.

Select Maintenance > Payments > Tenders > Tender tab.
Select an unused number from the ‘Number’ drop-down list and press Enter.
Type a name for the tender such as ‘Canadian Debit.’
Select the Type tab.
Select Debit.
Complete the rest of the tender configuration as normal.
Click Save and exit the Tenders funciton.

To configure the Paymentech processor for debit cards:
1.
2.
3.
4.
5.

Log in to Aloha EDC per your normal practice.
Select File > Stop POS Processing to gain access to the Configure menu.
Select Configure > Processors to access the Select Processor dialog box.
Select Add > Paymentech to add Paymentech to the list of active processors.
Select Paymentech from the list of active processors, and then select OK to configure the processor.
6. Use information provided by PaymenTech and Radiant Systems to configure PaymenTech as an
active, viable processor.
7. Select OK to close the dialog box back to the main EDC user interface.

EDC Enhancement Release v6.5
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8. Select File > Start POS Processing to resume processing payment cards.
Refer to the Debit Cards Feature Focus Guide for more information on configuring and using
debit cards.
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Supporting Timeout Ability in Aloha EDC
Version

RFC Number

EDC v6.5.5 RFC 44650
RFC 73342

Products

Audience

Aloha QuickService, Aloha TableService,
Aloha EDC

Configuration TechnicianStore Manager

In Aloha EDC v6.5.5, the system now logs off the current user after a specified length of time with no
activity by the user. The screen reappears, forcing the user to log back in to the application. EDC uses the
existing screen timeout value specified in Aloha Manager for the back office security level to which the
currently logged in user is assigned. Note: The maximum length of time a user can be logged in to EDC
without activity is 15 minutes, regardless of the the time set in Aloha Manager.

Figure 2 Back Office Security Levels Function
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Standardizing Credit and Debit Vouchers
Version

RFC Number

Products

Audience

EDC v6.5

RFC 59305

Aloha QuickService, Aloha TableService,
Aloha EDC

Configuration Technician
Store Manager

In v6.5, the Aloha POS system now prints credit and debit vouchers to conform with the 2006 Visa Receipt
Requirements. These changes include hard-coded fields without the option to alter them and ensures Aloha
customers are always in compliance with the new standards, regardless if you are printing or reprinting the
voucher.

This standardization does not affect Canadian debit vouchers.

Figure 3 and Figure 4 show the required fields for the credit and debit vouchers. You can also configure
additional areas, such as a check message, a footer, and custom text lines, in Maintenance > Store Settings
> Credit Card group.

When configured, the
text from the ‘Print
Check Message’ feature
prints here.

When configured, the
text from the ‘Custom
Text Lines’ feature prints
here.
When configured, the
text from the ‘Voucher 14’ text boxes, such as
‘Customer Copy,’ prints
here.

When configured, the
text from the ‘Print
Footer on Message’ feature prints here.

Figure 3 Credit Voucher
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When configured, the
text from the ‘Print
Check Message’ feature
prints here.

When configured, the
text from the ‘Custom
Text Lines’ feature prints
here.
When configured, the
text from the ‘Print
Footer on Message’ feature prints here.

When configured, the
text from the ‘Voucher 14’ text boxes, such as
‘Customer Copy,’ prints
here.

Figure 4 Debit Voucher

Some required fields do not print based on connectivity or the processor, such as the following:
•
•

The ‘Approval’ field does not print when the system is in spooling mode.
The ‘Merchant ID’ and ‘Terminal ID’ fields print only when using RBS WorldPay.
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Page 13

Supporting Partial Authorizations with Paymentech

Supporting Partial Authorizations with
Paymentech
Version

RFC Number

EDC v6.5.1 RFC 61214

Products

Audience

Aloha EDC

Configuration Technician,
Store Managers

In Aloha EDC v6.4, you could configure the Amex processor to accept prepaid American Express cards.
Support for prepaid cards, also known as partial authorization, are increasing in popularity and are now
adopted by Visa, Discover, and Master Card. In EDC v6.5, you can now configure the Paymentech processor to accept all prepaid cards, including American Express.
Supported EDC Processor

Prepaid Card Brand

Amex
Paymentech

American Express prepaid cards.
American Express, Discover, Master Card, and Visa prepaid cards.

Aloha QuickService and TableService v6.5 and Aloha EDC v6.5 are required to support partial
authorizations with Paymentech, so you must upgrade both applications to take advantage of this
new capability. If you are using an earlier version of Aloha, enabling the new capability in EDC
can have unpredictable results.
To configure partial authorizations with Paymentech:
1.
2.
3.
4.

Log in to Aloha EDC.
If POS processing is turned on, select File > Stop POS Processing.
Select Configure > Processors to display the Select Processor dialog box.
If Paymentech is not listed as a configured processor, click Add, select Paymentech from the list,
and click OK.
5. Select Paymentech from the list of configured processors and click Select. The Paymentech processor configuration dialog box appears.

EDC Enhancement Release v6.5
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6. Select the Options tab.

Figure 5 Paymentech - Options Tab

7. Select Credit Card Prepaid Transactions.
Credit Card Prepaid Transactions — Allows this processor to support credit cards that contain
a prepaid balance. You must select either ‘Auth with Balance’ or ‘Partial Authorization’ in conjunction with this option.
8. Select one of the following:
Auth with Balance — Allows you to send an authorization for an amount equal to or less than the
card balance only. An authorization for an amount greater than the card balance is declined.
Partial Authorization — Allows you to send an authorization for an amount equal to, less than,
or greater than the amount of the card balance. If the card is depleted and there is a remaining balance on the check, an amount due appears on the check for payment. Related Options: We highly
recommend you type ‘0’ in the ‘Assume this Tip% for Authorization’ text box in Maintenance >
Store Settings > Credit Card group > EDC Setup tab.
9. Click OK.
Regardless of how you configure EDC to respond to a partial authorization request, when the balance on
the card equals or exceeds the authorization request (meal plus tip), Paymentech processes the transaction
exactly the same way it does for a standard credit card, except it provides the card balance. The Aloha
Front-of-House (FOH) can only respond in three ways, depending on the EDC configuration:
EDC Enhancement Release v6.5
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•
•
•

Approve the transaction, and provide the card balance after the current transaction.
Decline the transaction, and provide the current card balance.
Partially approve the transaction, indicate the card balance is zero, and provide the balance due on
the transaction.

SCENARIO: The customer presents a prepaid card in payment for their meal, which costs exactly $10.00.
The authorization request determines there is only $8.00 left on the card. Schematically, the transaction is
as follows:
Cost of the meal:
Card balance before
transaction:

$10.00
$8.00

EDC Configured with ‘Auth with Balance’ Selected
EDC sends the transaction, along with a ‘terminal capable’ signal to the Paymentech processor, which
responds in one of two ways:
•

•

If the authorization request (meal plus tip) is greater than the balance remaining on the card, Paymentech returns a decline, and the current card balance. The payment request fails, and EDC
records the results in the .ans file. In the example scenario, Paymentech returns a decline, and a
card balance of $8.00.
If the authorization request (meal plus tip) is less than or equal to the balance remaining on the
card, Paymentech returns an approval, and the card balance after the transaction. The payment
request succeeds, and EDC records the results in the .ans file.

If, in the second case, the card balance had been $13.00 or $10.00, Paymentech would have returned an
approval in both cases, and reported a card balance of $1.00 and zero, respectively.

EDC Configured with ‘Partial Authorization’ Selected
EDC sends the transaction, along with a ‘terminal capable’ signal to the Paymentech processor, which
responds in one of two ways:
•

•

If the authorization request (meal plus tip) is greater than the balance remaining on the card, Paymentech returns a ‘partially authorized’ value, and the card balance, which in this case is always
zero. The payment request succeeds, and EDC records the results in the .ans file. Aloha adjusts the
payment due on the check in accordance with the amount approved by the processor. In the example scenario, Aloha accepts $8.00 in payment, reports a card balance of zero, and shows $2.00 still
owed on the transaction.
If the authorization request (meal plus tip) is less than or equal to the balance remaining on the
card, Paymentech returns an approval, and the card balance after the transaction. The payment
request succeeds, and EDC records the results in the .ans file, exactly as in the previous example.

Prepaid Card ‘Business Rules’
Configuring the Paymentech processor to allow partial authorizations for prepaid cards can result in revenue losses, in certain circumstances, based on the ‘business rules’ by which authorizations occur.
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If the balance on the card is less than the authorization request (meal plus 20%), but more than the base
transaction, Paymentech approves the full amount remaining on the card, counting any funds above the
base transaction as the tip, and reports the card balance as zero.
Using the example scenario, above, if the card balance had been $11.00, Paymentech would approve the
authorization for the full $11.00, counting $10.00 for the meal and $1.00 for the tip, and returning a card
balance of zero. The remaining $1.00 pending for the tip must come from the customer in some other form
of payment. If the customer has already left the premises, this payment is lost.

Voids and Prepaid Cards
If it becomes necessary to process a void against a charge made on a prepaid card, it is important to realize
that the returned funds will not be available on the card until settlement takes place, most often at the end
of the business day.
If the initial transaction was $30.00 against a $100.00 starting balance, followed by a void of $9.00, the
funds available on the card will be $70.00 until settlement restores the $9.00 void to the card balance. If the
starting balance was $30.00 in the same scenario, the funds available on the card will be $0.00 until settlement restores the $9.00 void.

EDC Enhancement Release v6.5
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Introducing Token Replacement
Version

RFC Number

EDC v6.5.3 RFC 63625
POS v6.5.2 RFC 63628
RFC 79929

Products

Audience

Aloha EDC

Configuration Technician
Store Manager

Radiant Systems introduces Token Replacement, a new payment security feature that allocates a unique
identifier, or token, to cardholder data at the RBS WorldPay host, to prevent personal information from
being stored at the point of sale. When using Token Replacement, sensitive cardholder data is sent to the
secure RBS WorldPay host in an encrypted form. The host processes the payment and assigns a unique
identifier, or token, to the transaction. The token is sent back to the point of sale for future reference, thus
eliminating the storage of sensitive credit card data in a recognizable form at the site and increasing data
security.
Token Replacement is only available to Radiant Payment Services / RBS WorldPay customers
and requires use of Aloha POS v6.5.2 or later and Aloha EDC v6.5.3 or later.

EDC Transaction Process using RPS
1.
2.
3.
4.
5.
6.
7.
8.

The site enters the credit or debit card into the Aloha POS system.
The primary account number is encrypted in the log file (Trans.log).
The transaction is sent to a Token Replacement certified processor for authorization.
Upon authorization, the processor replaces the primary account number in the transaction file with
a token.
The site receives the authorization from the processor.
The primary account number is removed from the log file (Trans.log).
At settlement, the transaction is sent to the processor using the token, not the primary account
number.
The processor approves the settlement with the primary account number not present in the settlement file.
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Exceptions to When Processor Replaces Cardholder Data with a Token
A token is issued by the processor for each transaction. The POS supports some transaction types that are
not submitted to the processor immediately and these transactions will not contain a token. The transaction
types are:
Refund
Force

Decline

Spooling

Performed locally and is not sent to processor until settlement. Authorization is not
received from the processor; therefore, the transaction will not contain a token.
Performed locally, sometimes with voice approval, and is not sent to the processor
until settlement. Authorization is not received from the processor; therefore, the
transaction will not contain a token.
Can occur without connecting to the processor. Whether the system connects to the
processor or not, the processor does not support generating a token. The transaction will not contain a token.
While in spooling mode, all transactions occur locally on the POS system and do not
connect to the processor. All transactions generated while in spooling mode will not
contain a token.

The sensitive card data for these transactions is always stored in an encrypted format. Your ability to view the full account number in the Audit Report is based on your back office security
level.

Configuring Token Replacement
Customers upgrading to Aloha v6.5 are not always automatically enabled for Token Replacement:
•

•

If you are an Aloha user who was initially using RBS WorldPay and you elected to move to Radiant Payment Services, you are not required to change your processor configuration from RBS
WorldPay to Radiant Payment Services but you must enable Token Replacement for the RBS
WorldPay processor in Aloha EDC, upon upgrading to Aloha v6.5.
If you are a new Aloha user, configure Radiant Payment Services as your payment processing provider and Token Replacement will automatically be enabled for you in Aloha EDC.

To configure RBS WorldPay to use Token Replacement:
1.
2.
3.
4.
5.
6.
7.
8.

Log in to Aloha EDC v6.5 or later.
Select File > Stop POS Processing, if this is started.
Select Configure > Processors.
Select RBS WorldPay.
Select the Options tab.
Select Enable Aloha Payment Guard or Enable Token Replacement.*
Click OK and exit the Processors function.
Select File > Start POS Processing.

EDC Enhancement Release v6.5
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Token Replacement will be in place the next time you process a credit card transaction, ensuring you are
storing credit card data in an unrecognizable form at the site level and protecting your system from potential hackers.
*The Aloha Payment Guard name was changed to Token Replacement, effective EDC v6.5.17, to
reflect the new product name.
After the token has been inserted, the full encrypted account number is no longer stored on the POS system. When you view the Audit report, regardless of your back office security level, the middle digits of the
account number are replaced with ‘Xs,’ similar to the EDC Transaction report and the EDC voucher. You
must contact the processor and provide pertinent information, such as the transaction date, amount of purchase, last four digits of the account number, and answer identifying questions.
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Supporting Partial and Split Payments with Chip
and PIN
Version

RFC Number

Products

Audience

v6.5

RFC 63711

Aloha QuickService, Aloha TableService

Configuration Technician
Store Manager

Chip and PIN, as implemented in the UK, now supports partial payments. Customers can use the partial
payments process to split checks. The process is as follows:
1. The customer announces they are going to use a Chip and PIN card to pay their bill.
2. The server returns to the FOH, and assigns the bill to a wireless payment card reader with Chip and
PIN capability.
3. The server hands the card reader device to the customer.
4. The customer inserts, or otherwise presents their Chip and PIN card to the device appropriately,
depending on the model.
5. The customer indicates on the card reader the amount they intend to pay with the Chip and PIN
card, and the amount they wish to pay as a tip, which the Aloha system tracks separately from the
original amount of the bill.
6. The customer enters the PIN on the device, when prompted.
7. The device obtains authorization for the combined amounts, bill plus tip.
The system initiates a new Chip and PIN request only after receiving authorization for the pending request.
8. The server and the customer finalize the payment with a printed receipt, which may require a signature, depending on site configuration.
9. The system immediately initiates another Chip and PIN payment request, assuming the first customer elected to pay less than the total amount, effectively splitting the bill.
10. The server hands the card reader device to the next customer at the table.
11. The process repeats, beginning with Step 4, above, until the entire bill has been paid.
If, at any point in the process, one of the customers obtains authorization for only a portion of the specified
amount they want to pay, they must use an alternate form of payment to pay their portion of the bill, such
as cash, or another payment card. The server passes the card reader device to the next customer at the table
who wants to pay with a Chip and PIN card.
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Supporting AVS with Paymentech
Version

RFC Number

Products

Audience

v6.5.1

RFC 63993

Aloha EDC, Aloha QuickService, Aloha
TableService

Configuration Technician
Store Manager

To increase fraud protection, many credit card companies offer reductions in credit card fees to merchants,
if they submit the cardholder’s zip code with the transaction for verification. This verification is referred to
as an Address Verification System (AVS). The Aloha system can capture and include the cardholder’s zip
code in the files sent to certain processors.
In EDC and POS v6.5.1, you can now use Paymentech as a supported processor for AVS. Additionally,
Paymentech and RBS WorldPay return an AVS response code on the printed voucher so the merchant can
decide whether to take action on a transaction that does not match the cardholder’s zip code on file.
The following table summarizes processors accepting the AVS code, as of the date of publication:
Processors Accepting the AVS Code with
Aloha

Accepts
AVS Code?

Returns AVS
Response Code

BA Merchant Services
Yes
No
Paymentech (Chase Paymentech)
Yes
Yes
RBS WorldPay
Yes
Yes
Visanet (TSys)
Yes
No
Contact your processor for specific information about AVS code acceptance and related requirements,
before configuring Aloha to request the AVS code.

Refer to the Address Verification System Feature Focus Guide for more information on processors supported by the Aloha system with AVS.
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Improving PMS Sales Category Messaging
Version

RFC Number

Products

Audience

v6.5.3

RFC 68643

Aloha QuickService, Aloha TableService,
PMS

Configuration Technician

The EDCSvr module now reads all 16 PMS sales categories that you can configure in Aloha Manager. The
sales category is included in the request message to the PMS host. Additionally, you can also use up to 19
characters, when you enter the room number in the FOH.
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Introducing Radiant Payment Services
Version

RFC Number

Products

Audience

v6.5.3

RFC 69164

Aloha EDC

Configuration Technician
Store Manager

Radiant Systems now introduces Radiant Payment Services (RPS), a new front-end offering developed in
partnership with the RBS WorldPay processor. Aloha users already using RBS WorldPay who elect to
move to Radiant Payment Services automatically receive the benefits of RPS with no changes made to the
terms of their agreement. Beginning in March 2009, your payment processing statements reflect the Radiant brand and contain a new customer service number.
Some benefits of using RPS include:
•
•
•
•

•

A single point of accountability for your restaurant POS technology from the time a card is swiped
to the settlement of funds.
Improved customer service specifically dedicated to our Aloha customers.
New products and services offered only to our Radiant Payment Services customers.
The automatic enabling of Token Replacement that inserts a “token” in place of credit card information, ensuring you are storing credit card data in an unrecognizable form at the site level and
protecting your system from potential hackers.
The ability to process over an SSL (secure socket layer), TCP/IP, or dialup connection.
Customers upgrading to Aloha v6.5 are not always automatically enabled for Token Replacement:
If you are an Aloha user who was initially using RBS WorldPay and you elected to move to Radiant Payment Services, you are not required to change your processor configuration from RBS
WorldPay to Radiant Payment Services but you must enable Token Replacement for the RBS
WorldPay processor in Aloha EDC, upon upgrading to Aloha v6.5. Refer to Introducing Token
Replacement.

If you are a new Aloha user, configure Radiant Payment Services as your payment processing provider and
Token Replacement is automatically enabled for you in Aloha EDC.
To configure Radiant Payment Services:
1.
2.
3.
4.

Log in to Aloha EDC.
If POS processing is turned on, select File > Stop POS Processing.
Select Configure > Processors to display the Select Processor dialog box.
If Radiant Payment Services is not listed as a configured processor, click Add, select Radiant
Payment Services from the list, and click OK.
5. Select Radiant Payment Services from the list of added processors and click Select. The Radiant
Payment Services processor configuration dialog box appears with the Setup tab selected.
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6. Complete the options on the Setup tab.

Figure 6 Radiant Payment Services - Setup Tab

7. Select and complete the options on the Options tab (Figure 7).
8. Select and complete the options on the TCP/IP tab (Figure 7).

Figure 7 Radiant Payment Services - Options Tab (Left) and TCP/IP Tab (Right)

9. Click OK.
10. Select File > Start POS Processing.
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Introducing EDC Audit Transaction Report
Version

RFC Number

Products

Audience

v6.5.4

RFC 73343

Aloha EDC

Configuration Technician
Store Manager

Aloha EDC 6.5.4 now offers the EDC Audit Transaction Report, available on the EDC Reports menu. This
PCI compliant report includes the following information for each transaction:
•
•
•
•
•
•
•
•
•

Date and time the transaction occurred.
The terminal ID from which the transaction was generated.
The employee number.
The check number.
The transaction type.
The type of credit card.
The card number (masked).
The expiration date.
The transaction amount.

Your ability to view the full account number in the EDC Audit Transaction Report is based on the same
function in Back Office Security Levels that controls the existing EDC Batch Transaction Report.
To view or print the EDC Audit Transaction Report:
1. In Aloha EDC, select Report > Audit Transactions. The Audit Batch Transaction dialog box
appears.
2. Select the batch(es) to report.
3. Select the card type(s).
4. Select the employee(s) to audit.
5. Select from the First Sort By inset to determine the first sort order.
6. Select from the Second Sort By inset to determine the second sort order after the ‘First Sort By.’
7. Select the Multi-Store Mode.
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8. Click View to view the report.

Figure 8 EDC Audit Transaction Report

9. Click Print to print the report, if desired.
10. Close the report.
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Adding PCI Disclaimer Message in EDC
Version

RFC Number

Products

Audience

v6.5.5

RFC 73596

Aloha EDC

Store Manager

To meet the requirements of the Payment Card Industry Security Standards Council, for Payment Application Data Security Standards validation, a disclaimer message now appears in EDC > Help > About.
To display the PCI disclaimer message:
1. In Aloha EDC, click Help > About. The disclaimer message appears.

Figure 9 About EDC Dialog Box

2. Click OK to exit the screen.
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