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Purpose of This Document

Purpose of This Document
This document contains instructions on how to set up and use the enhancements implemented in the EDC
v6.7.x enhancement release. In some instances, we combine features together to better explain the new
enhancements. When applicable, we include a scenario, how to configure the feature in Aloha® Manager,
how to use the feature in the Front-of-House (FOH), and references to other materials to fully implement
the feature. This document is not intended to fully explain a particular function or other options available
or surrounding the function. For your convenience, the material for each enhancement begins on a new
page, so you can properly remove and distribute the material to the necessary recipients. This document
does not guarantee the options discussed are in the same location, nor that the functionality remains the
same due to enhancements implemented in future versions of the affected products.

EDC Version Independence
With a stronger industry focus on payment application security, several of the larger card brands have created new specifications for communications (authorization and settlement) for payment applications. Since
the changes are security driven, the processors and banks involved have set mandatory deadlines for compliance with the new specifications.
Radiant Systems has introduced a ‘version independent’ Aloha EDC program, separate from the POS
products. Beginning with v6.4.0, Aloha EDC v6.4 is releasable and compatible with Aloha POS v5.3.15,
and higher, to eliminate the need for full POS upgrades to comply with these new card brand or processor
requirements.
You must upgrade your HASP key to Aloha v6.4 to run Aloha EDC v6.4. This change in license
status does not require you to upgrade to Aloha v6.4. If you are running an earlier version of
Aloha, you can still run Aloha EDC v6.4. For example, with the proper license, you can run
Aloha EDC v6.4 with Aloha POS v5.3, or v6.1. Please make the necessary arrangements to
upgrade all site keys prior to upgrading EDC.

Installation Methods for Aloha EDC v6.7
You can create an Aloha Update executable file to install Aloha EDC v6.7, or you can install it manually, if
you have the component files. We recommend you use the Aloha Update method, as this process uses the
rollback feature to restore the previous version immediately, if it encounters any problems. The rollback
feature can help you avoid downtime in your business, if the upgrade does not proceed as expected.
Refer to the SupportReady document, ‘Aloha Update,’ for information about how to create, configure, and use an Aloha Update executable file to upgrade your current EDC installation.
Use the following procedure, if you decide to install EDC v6.7 manually, without using an Aloha installation CD:
1. Process all outstanding transactions, and settle all pending batches. This step is of extreme
importance, to avoid losing sales data.
2. Stop POS Processing, in EDC.
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3. Unregistered Deceiver.
4. Install all prerequisites on the BOH file server:
a. Microstate.NET Framework 2.0 (required by processors using the Universal Payment Interface (UPI).
b. Microstate Visual C++ Redistributive 2005 SP1 (as VCRedist_x86.exe).
5. Use an Aloha Update file to upgrade your EDC installation, as described in the Supporters document, ‘Aloha Update.’
Or
Place the following files into the %Iberdir%\Bin directory, on the Aloha BOH file server, replacing any existing files of the same name:
a. AmexAlohaUPI.dll. Place this file in the %Iberdir%\Bin directory only if you want to use the
new CAPN, high speed authorization, settlement, and prepaid card functionality.
b. ChillkatDotNet2.dll.
c. Dbghelp.dll.
d. Edc.exe.
e. Edcsec.dll.
f. EdcSvr.dll.
g. EdcSvr.UpiClient.Interop.dll.
h. EdcSvrps.dll.
i. Ipwssl6.dll.
j. Log4net.dll.
k. NovaAlohaUPI.dll. Place this file in the %Iberdir%\Bin directory only if you want to use the
new Nova functionality.
6. Register EDCSvr. This step is required, regardless of installation method used.
7. Start POS Processing in EDC.
Refer to Radiant Knowledge System document number 5989 for more information about how to
unregister and register Aloha application files.
If you upgrade to EDC v6.7, and then use Aloha Update to upgrade your Aloha POS to a version
earlier than 6.7, this installation overwrites your previous EDC v6.5 installation. You must reinstall EDC v6.7 after upgrading your Aloha POS, but before you begin accepting transactions for
the new business day.
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List of Enhancements by Product
Version

RFC Number Description

EDC v6.7

RFC 18312

EDC v6.7

RFC 20487

EDC v6.7

RFC 73814
RFC 73815

EDC Enhancement Release v6.7

“Supporting eCommerce Transactions Through EDC to Fifth Third” on
page 6
“Remaining in Spooldown Mode Until All Transactions Are Processed”
on page 9
“Enhancing FDS Buypass for v6.7” on page 10
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Supporting eCommerce Transactions Through
EDC to Fifth Third
Version

RFC Number

Products

Audience

v6.7

RFC 75058

Aloha EDC

Configuration Technician
Store Manager

Aloha customers mostly use the Food/Restaurant industry code for credit and gift card transactions; however, Fifth Third Processing Solutions also supports eCommerce transactions. In EDC v6.7, you can configure the Fifth Third Processing Solutions processor to support eCommerce transactions via processor
indexing within Aloha EDC. You must configure another instance of the processor to use the eCommerce
industry code, and define an interface terminal or interface server from which to process eCommerce transactions.
The Fifth Third Processing Solutions processor also now supports the Mail Order/Telephone
Order (MOTO) industry code, which was required to receive the eCommerce certification.
To configure an instance of the Fifth Third Processing Solutions processor:
1.
2.
3.
4.

Log in to Aloha EDC.
If POS processing is started, select File > Stop POS Processing.
Select Configure > Processors. The Select Processor dialog box appears.
Click Add. The Select Processors to Add dialog box appears.

Figure 1 Select Processor to Add Dialog Box

5. Select Fifth Third Processing Solutions.
6. Type an instance of the processor in the ‘Store Index’ text box, such as ‘2’.
7. Click OK. You are returned to the Select Processor dialog box with another instance of Fifth Third
Processing Solutions appearing the list.
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8. Select the new instance of the Fifth Third processor and click OK. The configuration dialog box
appears.

Select eCommerce from
the ‘Industry’ drop-down
list for the instance of
the processor index.

Figure 2 Fifth Third Processing Solutions Dialog Box

9.
10.
11.
12.

Select eCommerce from the ‘Industry’ drop-down list.
Complete the remaining options for the processor, as appropriate.
Click OK.
Select File > Start POS Processing.

To configure an interface terminal or interface server from which to process the eCommerce transactions:
1. Select Maintenance > Hardware > Terminals.
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2. Select an unused number from the ‘Term ID’ drop-down list.

Figure 3 Terminals Function

3.
4.
5.
6.
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Select either Interface Terminal or Interface Server.
Type the indexing reference in the ‘EDC Info’ text box, such as ‘Index=2.’
Complete the remaining options on the Terminals function, as appropriate.
Click Save and exit the Terminals function.
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Remaining in Spooldown Mode Until All
Transactions Are Processed
Version

RFC Number

EDC v6.7.1 RFC 20487

Products

Audience

Aloha EDC

Configuration Technician
Store Manager

A large number of transactions can be waiting to process if a site has been in spooldown mode. To ensure
speed of service for real-time transactions that occur after an internet connection is re-established, Aloha
EDC v6.7 now continues to spool transactions until all pending transactions are processed. This ensures
current transactions do not time out.

EDC Enhancement Release v6.7

Page 9

Enhancing FDS Buypass for v6.7
Version

RFC Number

Products

Audience

EDC v6.7

RFC 73814
RFC 73815

Aloha EDC

Configuration Technician
Store Manager

We have made major enhancements to the FDS Buypass processor, formerly known as Concord EFS, in
EDC v6.7. The enhancements include:
•
•
•
•

RFC 73814 Supporting High Speed Credit Processing with FDS Buypass
RFC 73814 Supporting Partial Authorizations with FDS Buypass
RFC 73814 Supporting RFID with FDS Buypass
RFC 73815 Supporting Debit Transactions via FDS Buypass

Configuring High Speed Credit Processing With FDS Buypass
Prior to EDC v6.7, you could only enable high speed credit processing with FDS Buypass using the Merchant Link siteNet gateway. As of EDC v6.7, the Merchant Link siteNet gateway is no longer supported
and you can now use the FDS Secure Transport gateway. The IP address specified in the configuration dialog box is for a test account. You must contact FDS Buypass to obtain a valid IP address to use for production. You can still use a dialup connection for FDS Buypass.
To configure the FDS Secure Transport gateway for high speed connections:
1. In Aloha EDC, select Configure > Gateways.

Figure 4 Select Gateway Dialog Box
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2. Select FDS Secure Transport and click Select.

Figure 5 FDS Secure Transport Configuration Dialog Box

3.
4.
5.
6.

Type the IP address in the ‘First (Primary)’ text box.
Type the IP address in the ‘Second’ text box.
Click OK to return to the Select Gateway dialog box.
Click Done to exit.

Configuring the FDS Buypass Processor to Connect Via Gateway
Once you configure the FDS Secure Transport gateway, you can enable high speed communication with
FDS Buypass.
To configure the FDS Buypass processor to connect via gateway:
1. In Aloha EDC, select Configure > Processors. The Select Processor dialog box appears.
2. Click Add. The Select Processor to Add dialog box appears.
3. Select FDS Buypass and click OK. The Select Processor dialog box appears again with FDS Buypass in the list of processors.
4. Select FDS Buypass and click Select. The FDS Buypass configuration screen appears.
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5. Select the TCP/IP tab.

Figure 6 FDS Buypass - TCP/IP Tab

6. Select Connect using FDS Secure Transport.
7. Click OK.

Configuring Partial Authorizations with FDS Buypass
Support for prepaid cards, also known as partial authorization, are increasing in popularity and are now
adopted by Visa, Discover, and Master Card. In EDC v6.7, you can now configure the FDS Buypass processor to accept all prepaid cards.
To configure partial authorizations with FDS Buypass:
1.
2.
3.
4.

Log in to Aloha EDC.
If POS processing is turned on, select File > Stop POS Processing.
Select Configure > Processors to display the Select Processor dialog box.
If FDS Buypass is not listed as a configured processor, click Add, select FDS Buypass from the
list, and click OK.
5. Select FDS Buypass from the list of configured processors and click Select. The FDS Buypass
processor configuration dialog box appears.
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6. Select the Options tab.

Figure 7 FDS Buypass - Options Tab

7. Select Credit Card Prepaid Transactions.
Credit Card Prepaid Transactions — Allows this processor to support credit cards that contain
a prepaid balance. You must select either ‘Auth with Balance’ or ‘Partial Authorization’ in conjunction with this option.
8. Select one of the following:
Auth with Balance — Allows you to send an authorization for an amount equal to or less than the
card balance only. An authorization for an amount greater than the card balance is declined.
Partial Authorization — Allows you to send an authorization for an amount equal to, less than,
or greater than the amount of the card balance. If the card is depleted and there is a remaining balance on the check, an amount due appears on the check for payment. Related Options: We highly
recommend you type ‘0’ in the ‘Assume this Tip% for Authorization’ text box in Maintenance >
Store Settings > Credit Card group > EDC Setup tab.
9. Click OK.

EDC Enhancement Release v6.7

Page 13

Regardless of how you configure EDC to respond to a partial authorization request, when the balance on
the card equals or exceeds the authorization request (meal plus tip), FDS Buypass processes the transaction
exactly the same way it does for a standard credit card, except it provides the card balance. The Aloha
Front-of-House (FOH) can only respond in three ways, depending on the EDC configuration:
•
•
•

Approve the transaction, and provide the card balance after the current transaction.
Decline the transaction, and provide the current card balance.
Partially approve the transaction, indicate the card balance is zero, and provide the balance due on
the transaction.

SCENARIO: The customer presents a prepaid card in payment for their meal, which costs exactly $10.00.
The authorization request determines there is only $8.00 left on the card. Schematically, the transaction is
as follows:
Cost of the meal:
Card balance before
transaction:

$10.00
$8.00

EDC Configured with ‘Auth with Balance’ Selected
EDC sends the transaction, along with a ‘terminal capable’ signal to the FDS Buypass processor, which
responds in one of two ways:
•

•

If the authorization request (meal plus tip) is greater than the balance remaining on the card, FDS
Buypass returns a decline, and the current card balance. The payment request fails, and EDC
records the results in the .ans file. In the example scenario, FDS Buypass returns a decline, and a
card balance of $8.00.
If the authorization request (meal plus tip) is less than or equal to the balance remaining on the
card, FDS Buypass returns an approval, and the card balance after the transaction. The payment
request succeeds, and EDC records the results in the .ans file.

If, in the second case, the card balance had been $13.00 or $10.00, FDS Buypass would have returned an
approval in both cases, and reported a card balance of $1.00 and zero, respectively.

EDC Configured with ‘Partial Authorization’ Selected
EDC sends the transaction, along with a ‘terminal capable’ signal to the FDS Buypass processor, which
responds in one of two ways:
•

•

If the authorization request (meal plus tip) is greater than the balance remaining on the card, FDS
Buypass returns a ‘partially authorized’ value, and the card balance, which in this case is always
zero. The payment request succeeds, and EDC records the results in the .ans file. Aloha adjusts the
payment due on the check in accordance with the amount approved by the processor. In the example scenario, Aloha accepts $8.00 in payment, reports a card balance of zero, and shows $2.00 still
owed on the transaction.
If the authorization request (meal plus tip) is less than or equal to the balance remaining on the
card, FDS Buypass returns an approval, and the card balance after the transaction. The payment
request succeeds, and EDC records the results in the .ans file, exactly as in the previous example.
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Prepaid Card ‘Business Rules’
Configuring the FDS Buypass processor to allow partial authorizations for prepaid cards can result in revenue losses, in certain circumstances, based on the ‘business rules’ by which authorizations occur.
If the balance on the card is less than the authorization request (meal plus 20%), but more than the base
transaction, FDS Buypass approves the full amount remaining on the card, counting any funds above the
base transaction as the tip, and reports the card balance as zero.
Using the example scenario, above, if the card balance had been $11.00, FDS Buypass would approve the
authorization for the full $11.00, counting $10.00 for the meal and $1.00 for the tip, and returning a card
balance of zero. The remaining $1.00 pending for the tip must come from the customer in some other form
of payment. If the customer has already left the premises, this payment is lost.

Voids and Prepaid Cards
If it becomes necessary to process a void against a charge made on a prepaid card, it is important to realize
that the returned funds will not be available on the card until settlement takes place, most often at the end
of the business day.
If the initial transaction was $30.00 against a $100.00 starting balance, followed by a void of $9.00, the
funds available on the card will be $70.00 until settlement restores the $9.00 void to the card balance. If the
starting balance was $30.00 in the same scenario, the funds available on the card will be $0.00 until settlement restores the $9.00 void.

Supporting RFID with FDS Buypass
Some credit card companies, such as MasterCard, American Express, and Visa, have introduced contactless credit cards equipped with radio frequency identification (RFID) chips that allow guests to pay by tapping their card against a proximity reader device. These cards are also referred to as tapped cards. When
configured, the device captures the credit card number, name of the cardholder, and the credit card verification value (CVV) needed to charge against the guest’s account. In EDC v6.7, you can now use RFID with
FDS Buypass.
Refer to the RFID Feature Focus Guide for information in configuring the Aloha system to use
RFID.

Supporting Debit Transactions with FDS Buypass
Prior to EDC v6.7, only select processors supported debit transactions. As of EDC v6.7, you can now process debit transactions using FDS Buypass via dialup or using the FDS Secure Transport gateway. Refer to
“Configuring the FDS Buypass Processor to Connect Via Gateway” on page 11 for instructions on how to
configure the FDS Secure Transport gateway.
Refer to the Debit Cards Feature Focus Guide for more information on configuring and using
debit cards.

EDC Enhancement Release v6.7

Page 15

Page 16

EDC Enhancement Release v6.7

